<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>House Will Vote On Stimulus Bill Today, Majority Leader Says | Newstalk Florida - N</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.newstalkflorida.com/xmlrpc.php" />
    <link rel="icon" type="image/png" href="/wp-content/uploads/2017/01/favicon-16x16.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://newstalkfl.wpengine.com/wp-content/uploads/2017/01/apple-touch-icon-e1485880188258.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://newstalkfl.wpengine.com/wp-content/uploads/2017/01/apple-touch-icon-1-e1485880664885.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://newstalkfl.wpengine.com/wp-content/uploads/2017/01/android-chrome-192x192-1-e1485880632746.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://newstalkfl.wpengine.com/wp-content/uploads/2017/01/android-chrome-192x192-e1485880231361.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://newstalkfl.wpengine.com/wp-content/uploads/2017/01/apple-touch-icon-2-e1485880271764.png"/>
	<!-- This site is optimized with the Yoast SEO plugin v15.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Recent news from NewsTalk Florida. Click here to get details." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="House Will Vote On Stimulus Bill Today, Majority Leader Says | Newstalk Florida - N" />
	<meta property="og:description" content="Recent news from NewsTalk Florida. Click here to get details." />
	<meta property="og:url" content="https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/" />
	<meta property="og:site_name" content="Newstalk Florida - N" />
	<meta property="article:published_time" content="2021-03-09T13:03:00+00:00" />
	<meta property="article:modified_time" content="2021-03-08T19:17:39+00:00" />
	<meta property="og:image" content="https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI.jpeg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="666" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@newstalkflorida" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.newstalkflorida.com/#website","url":"https://www.newstalkflorida.com/","name":"Newstalk Florida - N","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.newstalkflorida.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/#primaryimage","inLanguage":"en-US","url":"https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI.jpeg","width":1000,"height":666,"caption":"In this March 27, 2020, photo, House Speaker Nancy Pelosi of Calif., walks to her office after signing the Coronavirus Aid, Relief, and Economic Security (CARES) Act on Capitol Hill in Washington. President Donald Trump wants to spend $2 trillion on infrastructure projects to create jobs and help the collapsing economy rebuild from the coronavirus' stunning blows. Pelosi says that seems about right. Sounds like the prelude to a bipartisan deal. Except that when it comes to trying to upgrade the country's road, rail, water and broadband systems, Washington frequently veers off the tracks \u2014 usually over the bill's contents and how to pay for it. (AP Photo/Andrew Harnik)"},{"@type":"WebPage","@id":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/#webpage","url":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/","name":"House Will Vote On Stimulus Bill Today, Majority Leader Says | Newstalk Florida - N","isPartOf":{"@id":"https://www.newstalkflorida.com/#website"},"primaryImageOfPage":{"@id":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/#primaryimage"},"datePublished":"2021-03-09T13:03:00+00:00","dateModified":"2021-03-08T19:17:39+00:00","author":{"@id":"https://www.newstalkflorida.com/#/schema/person/47e74d5a0b89f5c782bdbcc96001dbcc"},"description":"Recent news from NewsTalk Florida. Click here to get details.","breadcrumb":{"@id":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/"]}]},{"@type":"BreadcrumbList","@id":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.newstalkflorida.com/","url":"https://www.newstalkflorida.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/","url":"https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/","name":"House Will Vote On Stimulus Bill Today, Majority Leader Says"}}]},{"@type":"Person","@id":"https://www.newstalkflorida.com/#/schema/person/47e74d5a0b89f5c782bdbcc96001dbcc","name":"News Talk Florida","image":{"@type":"ImageObject","@id":"https://www.newstalkflorida.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fa63fe9dba9cc0bc4454acf902fd0459?s=96&d=blank&r=g","caption":"News Talk Florida"},"description":"News Talk Florida Staff","sameAs":["https://twitter.com/newstalkflorida"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="amphtml" href="https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/amp/" /><meta name="generator" content="AMP for WP 1.0.76"/><link rel='dns-prefetch' href='//js.hs-scripts.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Newstalk Florida - N &raquo; Feed" href="https://www.newstalkflorida.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Newstalk Florida - N &raquo; Comments Feed" href="https://www.newstalkflorida.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.newstalkflorida.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.newstalkflorida.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://www.newstalkflorida.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.2.6' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.newstalkflorida.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.newstalkflorida.com/wp-content/themes/Newspaper/style.css?ver=10.3.9.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-theme-child-css'  href='https://www.newstalkflorida.com/wp-content/themes/Newspaper-child/style.css?ver=10.3.9.1c' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.newstalkflorida.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://www.newstalkflorida.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://www.newstalkflorida.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=6b62588d33477b8e3dc5b8b3c9c8d86c' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://www.newstalkflorida.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=a50385a2d79d6600973a7e697f735a0b' type='text/css' media='all, print' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.newstalkflorida.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.4' type='text/css' media='all' />
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.2.6' id='tp-tools-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.2.6' id='revmin-js'></script>
<!-- This site uses the Better Analytics plugin.  https://marketplace.digitalpoint.com/better-analytics.3354/item -->
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/better-analytics/js/loader.php?ver=1.2.5.js' ></script><link rel="https://api.w.org/" href="https://www.newstalkflorida.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.newstalkflorida.com/wp-json/wp/v2/posts/141460" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.newstalkflorida.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.newstalkflorida.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://wp.me/p3QXpD-ANC' />
<link rel="alternate" type="application/json+oembed" href="https://www.newstalkflorida.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.newstalkflorida.com%2Ffeatured%2Fhouse-will-vote-on-stimulus-bill-today-majority-leader-says%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.newstalkflorida.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.newstalkflorida.com%2Ffeatured%2Fhouse-will-vote-on-stimulus-bill-today-majority-leader-says%2F&#038;format=xml" />
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/5633510/NewsTalkFloriday_Leaderboard_ATF', [[320, 50], [468, 60], [728, 90]], 'div-gpt-ad-1562785017007-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/5633510/NewsTalkFlorida_300_BTF', [[300, 100], [300, 250], [300, 600], [320, 50]], 'div-gpt-ad-1562870305980-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<!-- Segment Pixel - NewsTalkFlorida - DO NOT MODIFY -->
<img src="https://secure.adnxs.com/seg?add=18600105&t=2(43 B)
https://secure.adnxs.com/seg?add=18600105&t=2
" width="1" height="1" />
<!-- End of Segment Pixel -->			<!-- DO NOT COPY THIS SNIPPET! Start of Page Analytics Tracking for HubSpot WordPress plugin v7.51.34-->
			<script type="text/javascript">
				var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);
			</script>
			<!-- DO NOT COPY THIS SNIPPET! End of Page Analytics Tracking for HubSpot WordPress plugin -->
						<script>
				(function() {
					var hbspt = window.hbspt = window.hbspt || {};
					hbspt.forms = hbspt.forms || {};
					hbspt._wpFormsQueue = [];
					hbspt.enqueueForm = function(formDef) {
						if (hbspt.forms && hbspt.forms.create) {
							hbspt.forms.create(formDef);
						} else {
							hbspt._wpFormsQueue.push(formDef);
						}
					}
					if (!window.hbspt.forms.create) {
						Object.defineProperty(window.hbspt.forms, 'create', {
							configurable: true,
							get: function() {
								return hbspt._wpCreateForm;
							},
							set: function(value) {
								hbspt._wpCreateForm = value;
								while (hbspt._wpFormsQueue.length) {
									var formDef = hbspt._wpFormsQueue.shift();
									if (!document.currentScript) {
										var formScriptId = 'leadin-forms-v2-js';
										hubspot.utils.currentScript = document.getElementById(formScriptId);
									}
									hbspt._wpCreateForm.call(hbspt.forms, formDef);
								}
							},
						});
					}
				})();
			</script>
		<meta name="pubexchange:image" content="https://i0.wp.com/www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI-300x200.jpeg?w=300">
<meta name="pubexchange:title" content="House Will Vote On Stimulus Bill Today, Majority Leader Says">
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"12b0c0aba1","wpRestUrl":"https:\/\/www.newstalkflorida.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.newstalkflorida.com\/wp-admin\/","wpRestNonce":"12b0c0aba1","wpRestUrl":"https:\/\/www.newstalkflorida.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
			<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<meta name="generator" content="Powered by Slider Revolution 5.2.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>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</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-141754602-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-141754602-1');
</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.newstalkflorida.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.newstalkflorida.com/news/",
                    "name": "Florida"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.newstalkflorida.com/news/daytona/",
                    "name": "Daytona"                                
                }
            }
            ,{
                "@type": "ListItem",
                "position": 4,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/",
                    "name": "House Will Vote On Stimulus Bill Today, Majority Leader Says"                                
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #54a181;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #54a181;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #54a181;
                }
                .tdm-btn-style1 {
					background-color: #54a181;
				}
				.tdm-btn-style2:before {
				    border-color: #54a181;
				}
				.tdm-btn-style2 {
				    color: #54a181;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #54a181;
                    -moz-box-shadow: 0 2px 16px #54a181;
                    box-shadow: 0 2px 16px #54a181;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #54a181;
                    -moz-box-shadow: 0 4px 26px #54a181;
                    box-shadow: 0 4px 26px #54a181;
				}
</style>

<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-141460 single-format-standard td-standard-pack house-will-vote-on-stimulus-bill-today-majority-leader-says global-block-template-1 single_template_5 wpb-js-composer js-comp-ver-6.5.0 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/pages/News-Talk-Florida/160533280700031" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/newstalkflorida/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/newstalkflorida" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-96660" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first menu-item-96660"><a href="https://www.newstalkflorida.com/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-96645" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96645"><a href="https://www.newstalkflorida.com/news/tampa/">Tampa</a></li>
	<li id="menu-item-96646" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96646"><a href="https://www.newstalkflorida.com/news/saintpetersburg/">St. Petersburg</a></li>
	<li id="menu-item-96665" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96665"><a href="https://www.newstalkflorida.com/news/orlando/">Orlando</a></li>
	<li id="menu-item-96663" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96663"><a href="https://www.newstalkflorida.com/news/jacksonville/">Jacksonville</a></li>
	<li id="menu-item-96664" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96664"><a href="https://www.newstalkflorida.com/news/miami/">Miami</a></li>
	<li id="menu-item-96661" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96661"><a href="https://www.newstalkflorida.com/news/daytona/">Daytona</a></li>
	<li id="menu-item-96647" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96647"><a href="https://www.newstalkflorida.com/news/tallahassee/">Tallahassee</a></li>
	<li id="menu-item-96662" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96662"><a href="https://www.newstalkflorida.com/news/fortlauderdale/">Ft. Lauderdale</a></li>
	<li id="menu-item-96688" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96688"><a href="https://www.newstalkflorida.com/news/florida/">More</a></li>
</ul>
</li>
<li id="menu-item-96650" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-96650"><a href="https://www.newstalkflorida.com/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-96648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96648"><a href="https://www.newstalkflorida.com/politics/state/">State</a></li>
	<li id="menu-item-96691" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96691"><a href="https://www.newstalkflorida.com/politics/local/">Local</a></li>
	<li id="menu-item-96652" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96652"><a href="https://www.newstalkflorida.com/politics/national/">National</a></li>
	<li id="menu-item-96692" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96692"><a href="https://www.newstalkflorida.com/politics/world/">World</a></li>
</ul>
</li>
<li id="menu-item-96687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96687"><a href="https://www.newstalkflorida.com/entertainment/">Entertainment</a></li>
<li id="menu-item-96669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96669"><a href="https://www.newstalkflorida.com/podcasts/">Podcasts</a></li>
<li id="menu-item-96624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96624"><a href="http://www.sportstalkflorida.com/">Sports</a></li>
<li id="menu-item-121391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-121391"><a href="http://newstalkfl.wpengine.com/">Radio Lineup<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-137642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137642"><a href="https://www.newstalkflorida.com/radio-lineup/">Radio Lineup</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.newstalkflorida.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 6
-->


<div class="td-header-wrap td-header-style-6 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-4">
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/pages/News-Talk-Florida/160533280700031" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/newstalkflorida/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/newstalkflorida" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>    </div>        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, March 9, 2021
            </div>
        </div>
    </div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                
    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.newstalkflorida.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="https://www.newstalkflorida.com/">
			<img class="td-retina-data" data-retina="/wp-content/uploads/2016/04/news_talk_florida_logo-e1465832704673.png" src="/wp-content/uploads/2016/04/news_talk_florida_logo-e1465832704673.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://www.newstalkflorida.com/">
			<img class="td-retina-data" data-retina="/wp-content/uploads/2016/06/news_talk_florida_logo.png" src="/wp-content/uploads/2016/04/news_talk_florida_logo.png" alt=""/>
			<span class="td-visual-hidden">Newstalk Florida &#8211; N</span>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-96660"><a href="https://www.newstalkflorida.com/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96645"><a href="https://www.newstalkflorida.com/news/tampa/">Tampa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96646"><a href="https://www.newstalkflorida.com/news/saintpetersburg/">St. Petersburg</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96665"><a href="https://www.newstalkflorida.com/news/orlando/">Orlando</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96663"><a href="https://www.newstalkflorida.com/news/jacksonville/">Jacksonville</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96664"><a href="https://www.newstalkflorida.com/news/miami/">Miami</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96661"><a href="https://www.newstalkflorida.com/news/daytona/">Daytona</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96647"><a href="https://www.newstalkflorida.com/news/tallahassee/">Tallahassee</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96662"><a href="https://www.newstalkflorida.com/news/fortlauderdale/">Ft. Lauderdale</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96688"><a href="https://www.newstalkflorida.com/news/florida/">More</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-96650"><a href="https://www.newstalkflorida.com/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-96648"><a href="https://www.newstalkflorida.com/politics/state/">State</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96691"><a href="https://www.newstalkflorida.com/politics/local/">Local</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-96652"><a href="https://www.newstalkflorida.com/politics/national/">National</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-96692"><a href="https://www.newstalkflorida.com/politics/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-96687"><a href="https://www.newstalkflorida.com/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-96669"><a href="https://www.newstalkflorida.com/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-96624"><a href="http://www.sportstalkflorida.com/">Sports</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-121391"><a href="http://newstalkfl.wpengine.com/">Radio Lineup</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137642"><a href="https://www.newstalkflorida.com/radio-lineup/">Radio Lineup</a></li>
</ul>
</li>
</ul></div></div>            </div>
        </div>
    </div>

            <div class="td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  tdi_1_766 td_block_template_1">
<style>
/* custom css */
.tdi_1_766.td-a-rec{
					text-align: center;
				}.tdi_1_766 .td-element-style{
					z-index: -1;
				}.tdi_1_766.td-a-rec-img{
				    text-align: left;
				}.tdi_1_766.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_766.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><!-- radio buttons -->
<div class="rdio-bnnr tdc-content-wrap">
    <div class="tdc-row">
        <div class="vc_row wpb_row td-pb-row">
            <div class="tdc-row">
                <div class="vc_column wpb_column tdc-column td-pb-span6">
                    <a href="https://radio.securenetsystems.net/cirruscontent/WHBO" class="rdo-btn1" target="_blank"><span><i class="fa fa-headphones"></i> Listen Now</span> WHBO AM 1040</a>
                </div>
                <div class="vc_column wpb_column tdc-column td-pb-span6">
                    <a href="https://radio.securenetsystems.net/cirruscontent/WWBA" class="rdo-btn1" target="_blank"><span><i class="fa fa-headphones"></i> Listen Now</span> WWBA AM 820</a>
                </div>        
            </div><!-- /row -->    
        </div><!-- /wrapper -->
    </div>    
</div> 

<!-- Betting Ads -->
<div class="td-visible-desktop">
    <a href="https://record.revmasters.com/_bJjU4w1uv4vUOsjNOfgKeWNd7ZgqdRLk/1/" target="_blank"><img src="/wp-content/uploads/2021/01/leaderboard-ad-lg-rev1.jpg" alt="Bet on Sports" /></a>
</div>

<div class="td-visible-phone">
    <a href="https://record.revmasters.com/_bJjU4w1uv4vUOsjNOfgKeWNd7ZgqdRLk/1/" target="_blank"><img src="/wp-content/uploads/2021/01/mobile-leaderboard-lg-rev1.jpg" alt="Bet on Sports" /></a>
</div></div>
</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.newstalkflorida.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Florida" class="entry-crumb" href="https://www.newstalkflorida.com/news/">Florida</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Daytona" class="entry-crumb" href="https://www.newstalkflorida.com/news/daytona/">Daytona</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">House Will Vote On Stimulus Bill Today, Majority Leader Says</span></div></div>
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <article id="post-141460" class="post-141460 post type-post status-publish format-standard has-post-thumbnail category-daytona category-featured category-news category-fortlauderdale category-jacksonville category-local category-miami category-florida category-national category-orlando category-politics category-saintpetersburg category-tallahassee category-tampa" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">House Will Vote On Stimulus Bill Today, Majority Leader Says</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.newstalkflorida.com/author/admin/">News Talk Florida</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-09T08:03:00-05:00" >March 9, 2021</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.newstalkflorida.com%2Ffeatured%2Fhouse-will-vote-on-stimulus-bill-today-majority-leader-says%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=House+Will+Vote+On+Stimulus+Bill+Today%2C+Majority+Leader+Says&url=https%3A%2F%2Fwww.newstalkflorida.com%2Ffeatured%2Fhouse-will-vote-on-stimulus-bill-today-majority-leader-says%2F&via=newstalkflorida">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/&amp;media=https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI.jpeg&description=House+Will+Vote+On+Stimulus+Bill+Today%2C+Majority+Leader+Says">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=House+Will+Vote+On+Stimulus+Bill+Today%2C+Majority+Leader+Says %0A%0A https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content tagdiv-type">
            
<p><strong><em>Andrew Trunsky</em></strong> </p>



<figure class="wp-block-image size-large"><img loading="lazy" width="250" height="83" src="https://www.newstalkflorida.com/wp-content/uploads/2018/06/Daily-Caller-logo-3.png" alt="" class="wp-image-129699"/></figure>



<p>House Majority Leader Steny Hoyer said Saturday the House will vote on the Senate’s version of the coronavirus relief package on Tuesday, putting it on track to be signed into law before Mar. 14.</p>



<p>Hoyer&nbsp;<a href="https://twitter.com/LeaderHoyer/status/1368268040576634881" target="_blank" rel="noreferrer noopener">announced</a>&nbsp;the House’s schedule just after the Senate&nbsp;<a href="https://dailycaller.com/2021/03/06/senate-passes-trillion-covid-19-relief-bill-joe-biden-stimulus-checks/" target="_blank" rel="noreferrer noopener">passed</a>&nbsp;the bill 50-49 along party lines following over 24 hours of public and private&nbsp;<a href="https://dailycaller.com/2021/03/05/democratic-disagreement-biden-relief-covid-manchin-unemployment/" target="_blank" rel="noreferrer noopener">negotiations and debate</a>.</p>



<p>The House will consider the Senate’s changes to the $1.9 trillion package later Monday, Hoyer said. Unlike the House&nbsp;<a href="https://dailycaller.com/2021/02/27/american-rescue-plan-covid-19-coronavirus-relief-package-house-of-representatives-joe-biden/" target="_blank" rel="noreferrer noopener">version</a>, the Senate bill does not include provisions increasing the minimum wage and provides more targeted unemployment insurance provisions.</p>



<p>The minimum wage was excluded from the Senate bill after the chamber’s parliamentarian, Elizabeth MacDonough,&nbsp;<a href="https://dailycaller.com/2021/02/25/minimum-wage-senate-official-joe-biden-coronavirus-rescue-plan/" target="_blank" rel="noreferrer noopener">concluded</a>&nbsp;that it violated reconciliation rules. Her decision&nbsp;<a href="https://dailycaller.com/2021/03/01/progressives-biden-administration-overrule-senate-parliamentarian-15-minimum-wage/" target="_blank" rel="noreferrer noopener">frustrated progressives</a>, some of whom called for Vice President Kamala Harris to overrule her and include it.</p>



<p>Vermont Independent Sen. Bernie Sanders offered an amendment Friday that would have included a $15 minimum wage, but&nbsp;<a href="https://dailycaller.com/2021/03/05/seven-senate-democrats-vote-against-raising-minimum-wage-15-hour/" target="_blank" rel="noreferrer noopener">seven Democrats</a>&nbsp;and Maine Independent Sen. Angus King joined&nbsp; Republicans in voting against it.</p>



<p>Senate negotiations stalled for hours on Friday after West Virginia Sen. Joe Manchin objected to the Democrats’ preferred unemployment insurance plan, though he and his caucus eventually agreed on a compromise.</p>



<p>The Senate bill still includes $1,400 stimulus checks for qualifying Americans, though the checks became&nbsp;<a href="https://dailycaller.com/2021/03/03/biden-and-senate-democrats-reportedly-reduce-max-salary-for-coronavirus-stimulus-checks-by-20000/" target="_blank" rel="noreferrer noopener">more targeted</a>&nbsp;after President Joe Biden reached a compromise with moderate Senate Democrats. It also provides weekly $300 unemployment checks through Sept. 6, unlike the House version which provides $400 checks through Aug. 29.</p>



<p>If the bill passes the House, which is likely, it will head to Biden’s desk to be signed into law. The president said Saturday during a&nbsp;<a href="https://www.youtube.com/watch?v=0poIgyDm9E8" target="_blank" rel="noreferrer noopener">press conference</a>&nbsp;that qualifying Americans will begin receiving checks this month.</p>



<p>Though Biden originally called for the bill to be passed on a bipartisan basis, he and congressional Democrats&nbsp;<a href="https://dailycaller.com/2021/01/29/democrats-push-massive-stimulus-republican-objections/" target="_blank" rel="noreferrer noopener">pushed ahead</a>&nbsp;despite unanimous Republican opposition after the two sides were unable to compromise. Democrats were eager to pass the bill before Mar. 14, when unemployment benefits extended last December are set to expire.</p>



<p>Content created by The Daily Caller News Foundation is available without charge to any eligible news publisher that can provide a large audience. For licensing opportunities of our original content, please contact&nbsp;<a href="mailto:licensing@dailycallernewsfoundation.org">licensing@dailycallernewsfoundation.org.</a></p>
<div class="td-a-rec td-a-rec-id-content_bottom  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p tdi_2_54a td_block_template_1">
<style>
/* custom css */
.tdi_2_54a.td-a-rec{
					text-align: center;
				}.tdi_2_54a .td-element-style{
					z-index: -1;
				}.tdi_2_54a.td-a-rec-img{
				    text-align: left;
				}.tdi_2_54a.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_54a.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id="div-gpt-ad-1437162924899-0" style="height:90px; width:728px;">
<script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1437162924899-0'); });
</script>

<div id="google_ads_iframe_/5633510/Main_Page_Leaderboard_0__container__" style="border: 0pt none;"><iframe id="google_ads_iframe_/5633510/Main_Page_Leaderboard_0" title="3rd party ad content" name="google_ads_iframe_/5633510/Main_Page_Leaderboard_0" width="728" height="90" scrolling="no" marginwidth="0" marginheight="0" frameborder="0" src="javascript:&quot;<html><body style='background:transparent'></body></html>&quot;" style="border: 0px; vertical-align: bottom;"></iframe></div></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.newstalkflorida.com%2Ffeatured%2Fhouse-will-vote-on-stimulus-bill-today-majority-leader-says%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=House+Will+Vote+On+Stimulus+Bill+Today%2C+Majority+Leader+Says&url=https%3A%2F%2Fwww.newstalkflorida.com%2Ffeatured%2Fhouse-will-vote-on-stimulus-bill-today-majority-leader-says%2F&via=newstalkflorida">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/&amp;media=https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI.jpeg&description=House+Will+Vote+On+Stimulus+Bill+Today%2C+Majority+Leader+Says">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=House+Will+Vote+On+Stimulus+Bill+Today%2C+Majority+Leader+Says %0A%0A https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>                        <div class="author-box-wrap"><a href="https://www.newstalkflorida.com/author/admin/"><img alt='' src='https://secure.gravatar.com/avatar/fa63fe9dba9cc0bc4454acf902fd0459?s=96&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/fa63fe9dba9cc0bc4454acf902fd0459?s=192&#038;d=blank&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.newstalkflorida.com/author/admin/">News Talk Florida</a></span></div><div class="td-author-description">News Talk Florida Staff</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/newstalkflorida" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>            <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="News Talk Florida"></span><meta itemprop="datePublished" content="2021-03-09T08:03:00-05:00"><meta itemprop="dateModified" content="2021-03-08T14:17:39-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="/wp-content/uploads/2016/04/news_talk_florida_logo.png"></span><meta itemprop="name" content="Newstalk Florida - N"></span><meta itemprop="headline " content="House Will Vote On Stimulus Bill Today, Majority Leader Says"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI.jpeg"><meta itemprop="width" content="1000"><meta itemprop="height" content="666"></span>        </footer>

    </article> <!-- /.post -->

    
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside id="text-2" class="td_block_template_1 widget text-2 widget_text">			<div class="textwidget"><br><div class="td_block_wrap td_block_7 td_block_widget td_uid_4_575ee1726ff96_rand td-pb-border-top" data-td-block-uid="td_uid_4_575ee1726ff96"><h4 class="block-title"><span>LISTEN NOW</span></h4><div id="td_uid_4_575ee1726ff96" class="td_block_inner"><div class="td-block-span12">
       <div class="td_module_6 td_module_wrap td-animation-stack" style="padding-bottom: 0px !important">
<div style="margin-bottom: 10px">
<strong><a href="https://radio.securenetsystems.net/cirruscontent/WHBO" target="_blank" rel="noopener"><img src="/wp-content/uploads/2016/07/speaker-xxl-e1467823755758.png" width="32" height="32" style="vertical-align:middle;margin-right: 10px"></img> WHBO AM 1040</a></strong></div>

<div>
<strong> <a href="https://radio.securenetsystems.net/cirruscontent/WWBA" target="_blank" rel="noopener"><img src="/wp-content/uploads/2016/07/speaker-xxl-e1467823755758.png" width="32" height="32" style="vertical-align:middle;margin-right:10px"></img> WWBA AM 820</a></strong></div>




</div>
</div>
</div>
</div>
		</aside><aside id="adwidget_imagewidget-4" class="td_block_template_1 widget adwidget_imagewidget-4 AdWidget_ImageWidget"><a target="_blank" href='https://chiefinternetmarketer.com/?utm_source=chief&utm_medium=banner&utm_campaign=chief_track&utm_content=banner' alt='Ad'><img style='width: 100%;' src='https://www.newstalkflorida.com/wp-content/uploads/2020/04/cimm-1.jpg' alt='Ad' /></a></aside><aside id="gform_widget-2" class="td_block_template_1 widget gform_widget-2 gform_widget"><h4 class="block-title"><span>Contact Us</span></h4><link rel='stylesheet' id='gforms_reset_css-css'  href='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.3.6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.3.6' id='gform_json-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.3.6' id='gform_gravityforms-js'></script>
<script type="text/javascript"> var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.newstalkflorida.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.newstalkflorida.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"}; </script>
                <div class='gf_browser_unknown gform_wrapper newsletter_wrapper' id='gform_wrapper_2' ><a id='gf_2' class='gform_anchor' ></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_2' id='gform_2' class='newsletter' action='/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/#gf_2'>
                        <div class='gform_body'><ul id='gform_fields_2' class='gform_fields top_label form_sublabel_below description_below'><li id='field_2_2'  class='gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible' ><div class="newsletter-header">NewsTalk Florida Newsletter
</div>
<div class="newsletter-text">Get the latest news in your inbox.</div></li><li id='field_2_1'  class='gfield newsletter-input gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_1' ><span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_1' id='input_2_1' type='text' value='' class='large' tabindex='1'   placeholder='your@email.com' aria-required="true" aria-invalid="false"/>
                        </div></li><li id='field_2_3'  class='gfield gform_validation_container field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_3' >Email</label><div class='ginput_container'><input name='input_3' id='input_2_3' type='text' value='' /></div><div class='gfield_description'>This field is for validation purposes and should be left unchanged.</div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_2' class='gform_button button' value='Stay informed' tabindex='2' onclick='if(window["gf_submitting_2"]){return false;}  window["gf_submitting_2"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_2"]){return false;} window["gf_submitting_2"]=true;  jQuery("#gform_2").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=2&amp;title=&amp;description=&amp;tabindex=1' />
            <input type='hidden' class='gform_hidden' name='is_submit_2' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='2' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_2' value='WyJbXSIsIjk5ZjAxMDQyN2ZhZWMyNzA4OWExOTZhOTczMGFjNTMwIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_2' id='gform_target_page_number_2' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_2' id='gform_source_page_number_2' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_2' id='gform_ajax_frame_2'>This iframe contains the logic required to handle Ajax powered Gravity Forms.</iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 2, 'https://www.newstalkflorida.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_2').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_2');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_2').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_2').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_2').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_2').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_2').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_2').val();gformInitSpinner( 2, 'https://www.newstalkflorida.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [2, current_page]);window['gf_submitting_2'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_2').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_2').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [2]);window['gf_submitting_2'] = false;}, 50);}else{jQuery('#gform_2').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [2, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.newstalkflorida.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.newstalkflorida.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 2) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [2, 1]) } ); </script></aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                <div class="td-a-rec td-a-rec-id-footer_top  tdi_3_04a td_block_template_1">
<style>
/* custom css */
.tdi_3_04a.td-a-rec{
					text-align: center;
				}.tdi_3_04a .td-element-style{
					z-index: -1;
				}.tdi_3_04a.td-a-rec-img{
				    text-align: left;
				}.tdi_3_04a.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_04a.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><!-- /5633510/NewsTalkFlorida_Leaderboard_Floater -->
<div id='div-gpt-ad-1572635101858-0' style='width: 1px; height: 1px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1572635101858-0'); });
  </script>
</div></div>		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_block_widget tdi_4_294 td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="tdi_4_294" >
<style>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</style><script>var block_tdi_4_294 = new tdBlock();
block_tdi_4_294.id = "tdi_4_294";
block_tdi_4_294.atts = '{"custom_title":"Editor\u0027s Picks","custom_url":"","header_text_color":"#","header_color":"#","post_ids":"","category_id":"2","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","limit":"3","offset":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_4_294","block_type":"td_block_7","separator":"","block_template_id":"","m6_tl":"","show_modified_date":"","el_class":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_4_294","tdc_css_class_style":"tdi_4_294_rand_style"}';
block_tdi_4_294.td_column_number = "1";
block_tdi_4_294.block_type = "td_block_7";
block_tdi_4_294.post_count = "3";
block_tdi_4_294.found_posts = "8511";
block_tdi_4_294.header_color = "#";
block_tdi_4_294.ajax_pagination_infinite_stop = "";
block_tdi_4_294.max_num_pages = "2837";
tdBlocksArray.push(block_tdi_4_294);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Editor&#039;s Picks</span></h4></div><div id=tdi_4_294 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/featured/manchin-says-he-will-block-infrastructure-bill-if-republicans-arent-included/" rel="bookmark" class="td-image-wrap " title="Manchin Says He Will Block Infrastructure Bill If Republicans Aren’t Included" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2021/03/1000-2-2-100x70.jpeg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2021/03/1000-2-2-100x70.jpeg 100w, https://www.newstalkflorida.com/wp-content/uploads/2021/03/1000-2-2-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Manchin Says He Will Block Infrastructure Bill If Republicans Aren’t Included" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/featured/manchin-says-he-will-block-infrastructure-bill-if-republicans-arent-included/" rel="bookmark" title="Manchin Says He Will Block Infrastructure Bill If Republicans Aren’t Included">Manchin Says He Will Block Infrastructure Bill If Republicans Aren’t Included</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-09T10:17:00-05:00" >March 9, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/" rel="bookmark" class="td-image-wrap " title="House Will Vote On Stimulus Bill Today, Majority Leader Says" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI-100x70.jpeg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI-100x70.jpeg 100w, https://www.newstalkflorida.com/wp-content/uploads/2020/04/A.-PELOSI-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="House Will Vote On Stimulus Bill Today, Majority Leader Says" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/featured/house-will-vote-on-stimulus-bill-today-majority-leader-says/" rel="bookmark" title="House Will Vote On Stimulus Bill Today, Majority Leader Says">House Will Vote On Stimulus Bill Today, Majority Leader Says</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-09T08:03:00-05:00" >March 9, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/featured/fully-vaccinated-people-can-gather-without-masks-cdc-says/" rel="bookmark" class="td-image-wrap " title="Fully vaccinated people can gather without masks, CDC says" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2021/03/1000-6-1-100x70.jpeg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2021/03/1000-6-1-100x70.jpeg 100w, https://www.newstalkflorida.com/wp-content/uploads/2021/03/1000-6-1-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Fully vaccinated people can gather without masks, CDC says" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/featured/fully-vaccinated-people-can-gather-without-masks-cdc-says/" rel="bookmark" title="Fully vaccinated people can gather without masks, CDC says">Fully vaccinated people can gather without masks, CDC says</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-09T01:42:00-05:00" >March 9, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_block_widget tdi_5_ca6 td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="tdi_5_ca6" >
<style>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</style><script>var block_tdi_5_ca6 = new tdBlock();
block_tdi_5_ca6.id = "tdi_5_ca6";
block_tdi_5_ca6.atts = '{"custom_title":"Popular Stories","custom_url":"","header_text_color":"#","header_color":"#","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"jetpack_popular_2","limit":"3","offset":"3","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_5_ca6","block_type":"td_block_7","separator":"","block_template_id":"","m6_tl":"","show_modified_date":"","el_class":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_5_ca6","tdc_css_class_style":"tdi_5_ca6_rand_style"}';
block_tdi_5_ca6.td_column_number = "1";
block_tdi_5_ca6.block_type = "td_block_7";
block_tdi_5_ca6.post_count = "3";
block_tdi_5_ca6.found_posts = "6";
block_tdi_5_ca6.header_color = "#";
block_tdi_5_ca6.ajax_pagination_infinite_stop = "";
block_tdi_5_ca6.max_num_pages = "1";
tdBlocksArray.push(block_tdi_5_ca6);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Popular Stories</span></h4></div><div id=tdi_5_ca6 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/featured/carla-wallenda-a-member-of-the-sarasota-based-famed-high-wire-act-dies-at-85/" rel="bookmark" class="td-image-wrap " title="Carla Wallenda, a member of the Sarasota based famed high-wire act, dies at 85" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2016/11/1.-florida-obamacare-100x70.jpg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2016/11/1.-florida-obamacare-100x70.jpg 100w, https://www.newstalkflorida.com/wp-content/uploads/2016/11/1.-florida-obamacare-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Carla Wallenda, a member of the Sarasota based famed high-wire act, dies at 85" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/featured/carla-wallenda-a-member-of-the-sarasota-based-famed-high-wire-act-dies-at-85/" rel="bookmark" title="Carla Wallenda, a member of the Sarasota based famed high-wire act, dies at 85">Carla Wallenda, a member of the Sarasota based famed high-wire act,...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-08T00:00:00-05:00" >March 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/national-2/the-last-time-an-nfl-owner-had-to-leave/" rel="bookmark" class="td-image-wrap " title="The Last Time An NFL Owner Had to Leave" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2020/09/800-100x70.jpeg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2020/09/800-100x70.jpeg 100w, https://www.newstalkflorida.com/wp-content/uploads/2020/09/800-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="The Last Time An NFL Owner Had to Leave" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/national-2/the-last-time-an-nfl-owner-had-to-leave/" rel="bookmark" title="The Last Time An NFL Owner Had to Leave">The Last Time An NFL Owner Had to Leave</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-08T19:40:00-05:00" >March 8, 2021</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/featured/news-talk-floridas-bubba-the-love-sponge-begins-airing-his-successful-morning-show-launches-today-in-detroit-and-pittsburgh/" rel="bookmark" class="td-image-wrap " title="News Talk Florida&#8217;s Bubba The Love Sponge Begins Airing His Successful Morning Show Today in Detroit and Pittsburgh" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2016/12/Bubba-The-Love-Sponge-100x70.jpg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2016/12/Bubba-The-Love-Sponge-100x70.jpg 100w, https://www.newstalkflorida.com/wp-content/uploads/2016/12/Bubba-The-Love-Sponge-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Bubba" title="News Talk Florida&#8217;s Bubba The Love Sponge Begins Airing His Successful Morning Show Today in Detroit and Pittsburgh" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/featured/news-talk-floridas-bubba-the-love-sponge-begins-airing-his-successful-morning-show-launches-today-in-detroit-and-pittsburgh/" rel="bookmark" title="News Talk Florida&#8217;s Bubba The Love Sponge Begins Airing His Successful Morning Show Today in Detroit and Pittsburgh">News Talk Florida&#8217;s Bubba The Love Sponge Begins Airing His Successful...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-07-27T11:32:06-04:00" >July 27, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_block_widget tdi_6_37d td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="tdi_6_37d" >
<style>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</style><script>var block_tdi_6_37d = new tdBlock();
block_tdi_6_37d.id = "tdi_6_37d";
block_tdi_6_37d.atts = '{"custom_title":"Popular Interviews","custom_url":"","header_text_color":"#","header_color":"#","post_ids":"","category_id":"49","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","limit":"3","offset":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_6_37d","block_type":"td_block_7","separator":"","block_template_id":"","m6_tl":"","show_modified_date":"","el_class":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_6_37d","tdc_css_class_style":"tdi_6_37d_rand_style"}';
block_tdi_6_37d.td_column_number = "1";
block_tdi_6_37d.block_type = "td_block_7";
block_tdi_6_37d.post_count = "3";
block_tdi_6_37d.found_posts = "609";
block_tdi_6_37d.header_color = "#";
block_tdi_6_37d.ajax_pagination_infinite_stop = "";
block_tdi_6_37d.max_num_pages = "203";
tdBlocksArray.push(block_tdi_6_37d);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Popular Interviews</span></h4></div><div id=tdi_6_37d class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/news/florida/clearwater-redefines-relationship-between-city-and-tourists/" rel="bookmark" class="td-image-wrap " title="Clearwater Redefines Relationship Between City and Tourists" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2017/04/Clearwater-100x70.jpg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2017/04/Clearwater-100x70.jpg 100w, https://www.newstalkflorida.com/wp-content/uploads/2017/04/Clearwater-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Clearwater Redefines Relationship Between City and Tourists" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/news/florida/clearwater-redefines-relationship-between-city-and-tourists/" rel="bookmark" title="Clearwater Redefines Relationship Between City and Tourists">Clearwater Redefines Relationship Between City and Tourists</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-04T10:34:36-05:00" >March 4, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/video/florida-live-gregg-popovich-goes-after-trump-again/" rel="bookmark" class="td-image-wrap " title="Florida Live: Gregg Popovich Goes After Trump Again" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2017/05/pop-100x70.jpg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2017/05/pop-100x70.jpg 100w, https://www.newstalkflorida.com/wp-content/uploads/2017/05/pop-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Florida Live: Gregg Popovich Goes After Trump Again" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/video/florida-live-gregg-popovich-goes-after-trump-again/" rel="bookmark" title="Florida Live: Gregg Popovich Goes After Trump Again">Florida Live: Gregg Popovich Goes After Trump Again</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-02T09:05:34-05:00" >March 2, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.newstalkflorida.com/featured/relative-devastated-shooting-kills-8-mississippi/" rel="bookmark" class="td-image-wrap " title="Relative ‘devastated’ after shooting kills 8 in Mississippi" ><img width="100" height="70" class="entry-thumb" src="https://www.newstalkflorida.com/wp-content/uploads/2017/05/800-6-4-100x70.jpeg"  srcset="https://www.newstalkflorida.com/wp-content/uploads/2017/05/800-6-4-100x70.jpeg 100w, https://www.newstalkflorida.com/wp-content/uploads/2017/05/800-6-4-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Relative ‘devastated’ after shooting kills 8 in Mississippi" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.newstalkflorida.com/featured/relative-devastated-shooting-kills-8-mississippi/" rel="bookmark" title="Relative ‘devastated’ after shooting kills 8 in Mississippi">Relative ‘devastated’ after shooting kills 8 in Mississippi</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-25T16:09:07-05:00" >February 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>
        </div>
    </div>
<div class="td-footer-bottom-full">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.newstalkflorida.com/"><img class="td-retina-data" src="/wp-content/uploads/2016/04/news_talk_florida_logo.png" data-retina="/wp-content/uploads/2016/04/news_talk_florida_logo.png" alt="" title="" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Here at News Talk Florida we strive to use creativity and innovation in order to introduce our followers to new and distinctive angles. Our mission has always been to measure success through the growth and development of our talent and client partners.
<div class="footer-email-wrap">Contact us: <a href="mailto:contact@newstalkflorida.com">contact@newstalkflorida.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/pages/News-Talk-Florida/160533280700031" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/newstalkflorida/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/newstalkflorida" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-96720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-96720"><a href="https://www.newstalkflorida.com/advertising/">Advertising</a></li>
<li id="menu-item-96721" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-96721"><a href="https://www.newstalkflorida.com/contact-us/">Contact Us</a></li>
<li id="menu-item-96722" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-96722"><a href="https://www.newstalkflorida.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-96723" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-96723"><a href="https://www.newstalkflorida.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; 2021 Genesis Communications II, Inc. Powered by <a href="https://www.assorteddesign.com/" target="_blank">Assorted Design</a>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->


<meta id="ba_s" property="options" content="" data-o="{&quot;tid&quot;:&quot;UA-18841847-7&quot;,&quot;co&quot;:&quot;auto&quot;,&quot;g&quot;:1074135840,&quot;s&quot;:22,&quot;a&quot;:0,&quot;d&quot;:{&quot;c&quot;:[2,&quot;Daytona,Featured,Florida,Ft. Lauderdale,Jacksonville,Local,Miami,More Florida News,National,Orlando,Politics,St. Petersburg,Tallahassee,Tampa&quot;],&quot;a&quot;:[1,&quot;News Talk Florida&quot;]}}" /><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "news_talk_florida", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script>	<div style="display:none">
	<div class="grofile-hash-map-fa63fe9dba9cc0bc4454acf902fd0459">
	</div>
	</div>


    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        Speed booster: v4.2

        uid: 6047a34ad5aec
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.newsletter-header {
font-size: 18px;
font-weight: 700;
color: white;
margin-right: auto;
margin-left: auto;
display: table;

}
.newsletter_wrapper {
width: 300px !important;
background-color: #3e3e4a;
display: table;
margin-left: auto;
margin-right: auto;
border: 1px solid gray;

}
.newsletter-text {
   color: white;
   color: white;
margin-right: auto;
margin-left: auto;
display: table;
   
}

#gform_fields_2 {
    text-align: center;
    display:block;
        margin:0px auto;
        padding:0px;
}

#gform_submit_button_2 {
   display:block;
        margin:0px auto;
        background-color: #54a181;
        
}

#field_2_2 {
    padding: 0px !important;
}
#field_2_1 {
    padding: 0px !important;
  margin: -20px 10px 25px 10px !important;
    height: 48px !important;
}
.jwpWrapper {
  position: relative;
  padding-bottom: 56%;
  padding-top: 20px;
  height: 0;
}
.jwpWrapper iframe {
  position: absolute;
  top: 0;
  left: 0;
  width: 100%;
  height: 100%;
}
        
</style>

<div class="td-container"><script language="Javascript" src="//mgmt.firststreaming.com/listen/javascript/listen.js"></script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-0NTQBDN_xvK0m"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-0NTQBDN_xvK0m.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "18841687" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=18841687&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
<script>
    (function(w, d, t, r, u) {
        var f, n, i;
        w[u] = w[u] || [], f = function() {
            var o = {
                ti: "5525252"
            }

            ;
            o.q = w[u], w[u] = new UET(o), w[u].push("pageLoad")
        }, n = d.createElement(t), n.src = r, n.async = 1, n.onload = n.onreadystatechange = function() {
            var s = this.readyState;
            s && s !== "loaded" && s !== "complete" || (f(), n.onload = n.onreadystatechange = null)
        }, i = d.getElementsByTagName(t)[0], i.parentNode.insertBefore(n, i)
    })(window, document, "script", "//bat.bing.com/bat.js", "uetq");
</script><noscript><img src="//bat.bing.com/action/0?ti=5525252&Ver=2" height="0" width="0" style="display:none; visibility: hidden;" /></noscript>
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/70200/tag"></script>


<!-- Sublime Skinz Wallpaper - Start -->
<script type="text/javascript" src="https://ads.ayads.co/ajs.php?zid=23859"></script>
<!-- Sublime Skinz Wallpaper - End -->


<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/5633510/NewsTalkFlorida_Leaderboard_Floater', [1, 1], 'div-gpt-ad-1572635101858-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script></div>		<!-- Quantcast Tag -->
		<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-YJqhGWfYFD7zn",
				source:"wp"
			});
		</script>

		<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-YJqhGWfYFD7zn.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>
		<!-- End Quantcast tag -->
		<script type='text/javascript' id='leadin-script-loader-js-js-extra'>
/* <![CDATA[ */
var leadin_wordpress = {"userRole":"visitor","pageType":"post","leadinPluginVersion":"7.51.34"};
/* ]]> */
</script>
<script type='text/javascript' src='https://js.hs-scripts.com/2922550.js?integration=WordPress' async defer id='hs-script-loader'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.newstalkflorida.com/wp-content/plugins/gravityforms/js/placeholders.jquery.min.js?ver=2.3.6' id='gform_placeholder-js'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[141460]");
                });
            
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script src='https://stats.wp.com/e-202110.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4',blog:'56950449',post:'141460',tz:'-5',srv:'www.newstalkflorida.com'} ]);
	_stq.push([ 'clickTrackerInit', '56950449', '141460' ]);
</script>

</body>
</html>